Comment supprimer index.php dans mes URL sur Wordpress?

Bonjour, j’ai beaucoup travaillé sur un wordpress hébergé dans un sous répertoire de mon nom de domaine.
Je me rends compte que tous mes permaliens comprennent « index.php » avant le nom de l’article ou de la page.
Comment puis-je supprimer cela pour avoir simplement le nom de l’article ou de la page après le nom de domaine lorsque je migrerai mon site vers le répertoire racine?
Je galère sur ce point depuis quelques jours alors si l’un d’entre-vous pouvait me guider cela me ferait très plaisir en cette période de confinement :slight_smile:

Bonjour @Xavier_Danloy ,

L’ajout de index.php dans l’URL peut provenir de plusieurs raisons :

  • Regarde les permaliens ici : Tu peux éditer les Permaliens de ton site en allant dans ton espace administrateur : Réglages -> Permaliens

  • Regarde également dans Réglages -> Général : parfois index.php se glisse directement dans l’URL principale du site !

Grand merci Edouard pour ta réponse.
Regarde également dans Réglages -> Général: --> c’est fait et pas de index.php à cet endroit.
Regarde les permaliens ici : Tu peux éditer les Permaliens de ton site en allant dans ton espace administrateur : Réglages -> Permaliens --> j’y suis allé et ai tenté de supprimer « index.php » cela me donne ensuite une page erreur 404 :frowning:
C’est la gaga la gaga la galère lol
si je coche l’option « simple », cela fonctionne mais ce n’est pas ce que je souhaiterais…

Hello !

Tu dois choisir « personnalisée » et indiquer /%postname%/ par exemple. C’est ce qui devrait te convenir.
As-tu essayé cela ?

Hello Edouard,

Merci pour ta réponse.
Oui j’ai tenté cette combinaison. C’est justement ce qui me donne une erreur 404, comme si la page était introuvable sans le index.php devant le /%postname%
C’est effectivement ces tentatives infructueuses qui m’amenaient sur le forum dans l’espoir de trouver une solution…

Tu as d’autres pistes ici :

Tu as pu regarder ?

Merci beaucoup pour ton aide.
Malheureusement toutes les solutions évoquées ne donnent rien chez moi.
Etrange cette bizarrerie… :slight_smile:

Bonjour à tous,afin de répondre à ceux qui cherchent une piste un peu plus fouillee que 2 ou 3 pages de Google et d’apporter enfin une réponse à ce message, voici ce que j’ai du appliquer chez moi étant sur un autre serveur que les standards Ovh, one etc…
Mon site ne permettait pas le mode réécriture d’URL, soit une simple option à activer sur le serveur hébergeant le site web sur lequel je travaillais.
Autant en faire profiter la communauté :blush: