Couleurs widgets sur Wordpress

Bonjour,
J’utilise actuellement le thème TwentySeventeen pour lequel j’ai créé un thème enfant.
Je viens de rajouter des widgets sur la colonne latérale du blog de ma page actu, mais voilà, j’ai un problème de couleur et je n’arrive pas à en venir à bout.
Concrètement tout mon site est bleu, j’ai fait les modifs en partie dans la personnalisation du thème et en partie en dur dans le style.css.
Mais je n’arrive pas à venir à bout des widgets de la page blog.
J’ai regardé avec l’inspecteur, essayé plusieurs codes en css mais rien n’a l’air de fonctionner, alors s’il y a une âme charitable qui passe ici et qui peut m’aider ça serait super !
La page en question est

Et entre autres, j’ai testé avec :
#secondary h2.widget-title{color:#245fA5 !important;}
#secondary a.tag-cloud-link {color:#245fA5 !important;}
#secondary li.cat-item a{color:#245fA5 !important;}

Merci beaucoup ! :pray:

Hello,
Si tu veux changer la couleur de fond de la siderbar en elle même, c’est la div aside
Donc, dans ton code css :
#aside { background-color : #XXXXXX !important; }

1 J'aime

Super bizarre, j’ai mis ton code pour voir ce que ça donnait, en me disant que je risquais de toute façon d’avoir un pb de couleur d’écriture, mais ça a fait exactement ce que je voulais, c’est bizarre non car c’était bien le background qu’on changeait en faisant ça non ?
Est-ce que ça peut prendre du temps les modifs qu’on fait dans le CSS ?
Car les autres codes je les ai mis il y a 2 jours…
Merci en tous cas de ton aide !

Yep, on a effectivement changé la couleur du background.
Seulement, j’ai modifié la div Aside, danc le conteneur, là où toi, d’après le code que tu as copié, tu jouais sur le titre H2, sur la couleur du lien, et les éléments de liste li.

En outre, quand tu modifies le CSS, le changement est immédiat et répercuté dans la seconde sur l’ensemble du site.

Si cela à mis deux jours, tu dois sans doute utiliser un plugin de cache avec des réglages particuliers j’imagine.

Bah en fait c’est doublement bizarre…
J’avais les écritures en bleu partout ce matin, et maintenant sur Chrome chez moi c’est de nouveau noir… :see_no_evil:
Et le background n’a pas changé, toujours blanc.

Je fais les tests toujours sur chrome, firefox et safari, en sachant que sur firefox et safari, je vide tout l’historique, cookies et cie à chaque fois. Donc je vois pas pourquoi ça ne ferait rien sur ces navigateurs là ?

J’utilise WP Fastest cache mais j’ai gardé les réglages de base (capture d’écran ci-dessous) , donc c bizarre…

Il faut faire super attention avec la minification CSS et JS, il n’est pas rare que les thèmes et autres plugins le supporte mal. Procède par étape, désactive les deux, vide ton cache, et regarde comment le site se comporte.
Si tout est ok, active la minification CSS, et regarde. Et ainsi de suite.
Tu peux aussi carrément désactiver le cache et faire des tests pour voir ce que cela donne.

1 J'aime

Alors j’ai fait ça :
1/ désactivé le cache + modifié couleur des titres dans le CSS : effet immédiat sur Firefox
2/ réactivé le cache + décoché la minification HTML, CSS, combiner CSS et combiner JS + modifié couleur : effet immédiat
3/ réactivé à tour de rôle les 4 options en changeant la couleur à chaque étape : effet immédiat aussi…

Par contre ton code pour le background y est toujours mais aucun effet, le background est toujours blanc. J’ai peut être un truc qq part qui passe au-dessus, je sais pas ?
Test fait sur Firefox car sur Chrome, je vois toujours le contenu de la sidebar écrit en noir (mais pas sur mobile), c’est vraiment bizarre… Et pourtant j’ai bien vidé mon cache…

Merci de tes conseils en tous cas :slight_smile:

Tu as aussi le navigateur de ton cache qui peut te jouer des tours. Pense à la vider quand tu fais des modifications (: